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Date
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Description of Change

Manual was revised to include new web browser
interface screen captures.

Manual was revised to support IF61 firmware
version 2.1x.

Moved edgeware application information to new
documents:

* SAP Device Controller information, previously
in Appendix B, is now in the IF61 SAP Device
Controller User’s Guide (P/N 934-025-xxx).

* Application Level Engine (ALE) information,
previously in Chapter 3, is now in the IF61
Application Level Engine (ALE) User’s Guide
(P/N 934-026-xxx).

Added new information for RFID services,

including BRI and LLRP configuration settings,

and the Device Configuration web service.

Added information and procedures for

configuring, using, and troubleshooting the
802.11a/b/g radio.

Updated screen captures to match the revised web
browser interface.

Minor revisions made to RFID application
development sections.
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Before You Begin

Before You Begin

This section provides you with safety information, technical support
information, and sources for additional product information.

Safety Information

Your safety is extremely important. Read and follow all cautions in
this document before handling and operating Intermec equipment.
Your equipment and data can be damaged if you do not follow the
safety cautions.

This section explains how to identify and understand cautions and
notes that are in this document.

A caution alerts you to an operating procedure, practice,
condition, or statement that must be strictly observed to prevent

o equipment damage or destruction, or corruption or loss of data.
aution

Note: Notes either provide extra information about a topic or contain
special instructions for handling a particular condition or set of
circumstances.

Global Services and Support

Warranty Information

To understand the warranty for your Intermec product, visit the
Intermec web site at www.intermec.com, click Support > Returns and
Repairs, then click Warranty.

Disclaimer of warranties: The sample code included in this document
is presented for reference only. The code does not necessarily
represent complete, tested programs. The code is provided “as is with
all faults.” All warranties are expressly disclaimed, including the
implied warranties of merchantability and fitness for a particular
purpose.
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Chapter 3 — Developing and Using RFID Applications

Java Support for Microsoft SQL Server and Sybase

The IF61 jTDS driver (version 1.2) provides JDBC capabilities to Java
applications running on the IF61. You need to include the location of
the JDBC drivers in the class path. Use the environment variable
$JDBC_HOME as shown in this example:

$JAVA HOME/bin/java -cp $JDBC_HOME/jtds-j2me-
1.0.2.jar:. MyClass

The IF61 JDBC driver supports JDBC 1.0 and:
*  Microsoft SQL Server versions 6.5, 7, 2000, and 200S.
» Sybase versions 10, 11,12, and 15.

For more information on the jTDS driver, see
http://jtds.sourceforge.net.

IF61 JavaScript Support

The IF61 supports applications developed with JavaScript. Because
JavaScript RFID applications can generally be written quickly,
JavaScript is an ideal tool for creating demonstration or proof-of-
concept applications as well as production RFID software.

Installing RFID Applications on the IF61

The IF61 provides up to 1 GB of storage for your applications, and up
to 40 GB of storage with an optional hard drive. You use the web
browser interface to install applications on the IF61. For help, see the
next procedure.

.tar/gz. To install Intermec edgeware applications in .bin format, see

§ Note: The IF61 only supports these formats: .zip, .tar, .tar/bz2, and
“Upgrading or Installing Edgeware Applications” on page 64.

To install applications on the IF61

1 From the menu, click Edgeware Applications > Install User
Application. The Install User Application screen appears.
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Managing Applications

62

Navigation Menu

Intermec*
D

RFID

Install User Application

Wednesday, April

Interme;
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B RFID Services
B Edgeware Applications
Application Control
Install Edgeware
Install User Application
- Developer Tools
ALE Engine
- 1BM Data Capture and Delivery Platform
B ALE Store and Forward
B S5AP Device Controller
B Security
B8 Maintenance
About

User Application Installation

Select archive to upload:

Supported file type: Zp, tar/brZ, tar/oz, tar

gaload

v

2 Click Browse and follow the prompts to navigate to the location
of the application file.

3 Click Upload. The application is uploaded to the IF61.

To maximize IF61 resources, you can start, stop, or uninstall IF61
edgeware applications or your installed applications from the web
browser interface. You can also configure applications to auto-start at

boot time. For more information, see the next section.

To manage applications

1 From the menu, click Edgeware Applications > Application

Control. The Application Control screen appears.
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Navigation Menu
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SAP All Device Controller V4.02.00
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’— User Applications

Mo user applications installed
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Chapter 3 — Developing and Using RFID Applications

The Edgeware Applications section lists all installed edgeware. The
User Applications section lists all applications you have installed
through the web browser interface.

In this screen, you can:

 specify which applications automatically start when the IF61
boots.

* turn applications on and off in real time.
* uninstall applications (except for Developer Tools).
2 Choose an option:

* Check the Auto-Start check box if you want an application to
automatically launch when the IF61 boots.

* Click [#] to stop a running application.

¢ Click [#] to start an application.

e Click [¥] to uninstall an application.

* Click Activate Changes to save your changes and immediately
make them active.

running applications (or reboot the IF61) for the date and time
changes to be made effective.

§ Note: If you change the date or time on the IF61, stop and restart any

About the IF61 Edgeware Applications

Edgeware applications are supplied by Intermec and its partner
developers, and provide immediate functionality for your RFID
system. The IF61 includes these edgeware applications:

* The Developer Tools. Use the Developer Tools to test your RFID
systems and settings. For more information, see “About the
Developer Tools” on page 75.

* The SAP device controller. Enable this edgeware so the controller
communicates with the SAP backend module on your server. For
more information on SAP implementation on the IF61, see the
IF61 SAP Device Controller User’s Guide (P/N 934-025-xxx).
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Chapter 3 — Developing and Using RFID Applications

* The Application Level Events (ALE) Engine. Enable this edgeware
so the IF61 ALE engine communicates with your ALE application.
For more information on ALE implementation on the IF61, see
the IF61 Application Level Engine (ALE) User’s Guide (P/N 934-026-

* ALE Store and Forward. This application reads tags, saves tag
data, and fowards the data to a shared folder on a host PC or to a
TCP/IP socket. Store and Forward works as an ALE client using
the IF61 ALE engine. For more information, see the ALE Store and
Forward User’s Guide (P/N 934-034-xxx).

You can uninstall any edgeware application other than the Developer
Tools. For help, see the previous section, “Managing Applications.”

Intermec may provide upgrades for existing edgeware applications, as
well as additional edgeware applications you can install. For help with
locating IF61 upgrades at www.intermec.com, see “Accessing
Intermec Web Pages” on page 107. To install or upgrade edgeware
applications, see the next section.

Upgrading or Installing Edgeware Applications

%

64

You use the web browser interface to install or upgrade IF61 edgeware
applications, such as the SAP device controller or ALE engine. For
help, see the next procedure.

Note: Use only .bin files provided by Intermec. To install your own
applications in .zip, .tar, .tar/bz2, or .tar/gz formats, see “Installing
RFID Applications on the IF61” on page 61.

To install or upgrade edgeware

1 From the menu, click Edgeware Applications > Install
Edgeware. The Install Edgeware screen appears.
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Navigation Menu

Install Edgeware

Intermec Manual Help
Thursday, March 20, 2008 06:56:48

%

B8 Network Configuration

B8 RFID Services

B Edgeware Applications
Application Contral
Install Edgeware
Install User Application

& Developer Tools

S Engine

il ALE Store and Forward

B security

B Maintenance

About

of the .bin fi

le.

About RFID Services

The RFID service sets the protocol your application uses to
communicate with the RFID module. The available services are:

BRI (Basic Reader Interface) - Intermec proprietary protocol for

- Edgeware Installation -

Select archive to
upload:
Supported file
type:

|
|
Intermec .bin fies

}

Bionge.]| o=t |

Note: For information on uninstalling edgeware applications, see
“Managing Applications” on page 62.

controlling the reader. To configure BRI settings, see the next

section.

LLRP (Low-Level Reader Protocol) - EPCglobal standard for

network interfaces between the RFID reader and its controlling

software. To configure LLRP settings, see “Configuring LLRP
Settings” on page 74.

Configuring BRI Settings

el

2 Click Browse and follow the prompts to navigate to the location

3 Click Upload. The application file is installed on the IF61. When
the installation is complete, the IF61 reboots.

By default, the IF61 reader module uses BRI as its main protocol. This
section explains how to configure BRI settings that control reader
operation and communication with your application:
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* To configure BRI attribute settings that control reader operation,
such as read and write tries, tag types, or antenna settings, see the
next section, “Changing BRI Attribute Settings.”

» To configure BRI server settings, which manage how your
application communicates with the reader, see “Configuring the
BRI Server” on page 72.

Changing BRI Attribute Settings

BRI attribute settings control how the IF61 reader module reads tags.
Follow the next procedure to change attribute settings.

66

%

Note: The BRI attribute settings in the web interface define the
default BRI attributes when a client initially connects to the BRI. The
settings do not change the attributes of any current BRI sessions.

To change BRI attribute settings
1 From the menu, click RFID Services > BRI > BRI Attributes. The

BRI Attributes screen appears.

[ ) RFID
Navigation Menu

Intermec’

BRI Attributes

Intermec Manual Help
Tuesday, April 22, 2008 04:10:42

@ Network Configuration
B8 RFID Services
e
BRI Server
BRI Attributes

i BRI Log
L LRp
BB Edgeware Applications
- Security

~ @ Maintenance

About

2 Change RFID settings as needed.

r Tag Types

|
i EPC Class 1 Gen2
| Phillips v1.19

|

| 15068/G1

| IS06B/G2

3]

i [ |

Tag Operations

Read Tries
Wirite Tries

| Lock Tries

- Tag Reporting
Field Separator

ID Report.

No Tag Report

Report Timeout

il

|Space () [»

H &

=]

]

For help, see the next section.
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3 Click Activate Changes to save your changes and immediately
make them active.

About BRI Attribute Settings

This section explains the BRI attribute settings that control how the
reader operates. For more information, see the Basic Reader Interface
Programmer’s Reference Manual (P/N 937-000-xxx).

Tag Types
Check the appropriate check boxes to enable RFID operations for
these kinds of tags:

* EPC Class 1 Gen 2 (defaulr)

* Phillipsv1.19

. ISO6B/G1

. ISO6B/G2

This setting is equivalent to the TAGTYPE BRI attribute.

Read Tries
Sets the maximum number of times the read algorithm is executed
before a response is returned to a Read command.

In practice, this is the number of times an identified tag is read until
the Read is successful. Valid range is 1 to 254 (default is 3).

This setting is equivalent to the RDTRIES BRI attribute.

Wirite Tries
Sets the maximum number of times the write algorithm is executed
before a response is returned to a Write command.

In practice, this is the number of times an identified tag is written to
until the Write is successful. Valid range is 1 to 254 (default is 3).

This setting is equivalent to the WRTRIES BRI attribute.

Lock Tries

Sets the maximum number of times the lock algorithm is executed
before a response is returned to a Lock command. Valid range is 1 to
254 (default is 3).

IF61 Fixed Reader User’s Manual 67



Chapter 3 — Developing and Using RFID Applications
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This setting is equivalent to the LOCKTRIES BRI attribute.

Field Separator

Sets the space character to be used for separating fields in tag data.
Choose from space (), comma (,), colon (:), semicolon (;), tab, caret (%),
or tilde (7). Default is space.

This setting is equivalent to the FIELDSEP BRI attribute.

ID Report
Enables or disables tag ID reporting after a Read, Write, or Lock
command is executed:

* ForISO tags, the tag identifier corresponds to TAGID.
* For EPC tags, the identifier corresponds to EPCID.

Check the check box to enable tag ID reporting. This setting is
equivalent to the IDREPORT BRI attribute, and is enabled by default.

No Tag Report

Enables or disables a NOTAG message, which is sent when no tags are
found during execution of a Read, Write, or Lock command. Check
the check box to enable the message. This setting is equivalent to the
NOTAGRPT BRI attribute, and is enabled by default.

Report Timeout
Sets the timeout (in ms) for delays in tag reporting when the IF61 is in
continuous read mode. Range is 0 (default) to 65534.

Timeout Configuration Mode

Enables a timeout mode. Instead of specifying the number of antenna
or ID tries, you specify an antenna or ID timeout value. If the IF61
does not find any tags after an antenna or ID try, the reader waits this
long before starting the next antenna or ID try. If you enable timeout
mode, you need to set the ID Timeout and Antenna Timeout values.

This setting is equivalent to the TIMEOUTMODE BRI attribute, and
is disabled by default.
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To enable Timeout Configuration mode

1 Check the check box and then click Activate Changes. The screen
refreshes. The Antenna Tries setting is replaced by Antenna
Timeout, and the ID Tries setting is replaced by ID Timeout.

2 Specify the value (in ms) for the antenna or ID timeout in the
entry fields and then click Activate Changes.

For more information on ID Timeout and Antenna Timeout, see
those topics later in this section.

Select Tries

(Not supported by EPCglobal Class 1 Gen 2 tags) Sets the number of
times a group select is attempted. A group select is the command that
starts the identity process. Valid range is 1 (default) to 254.

This setting is equivalent to the SELTRIES BRI attribute.

Unselect Tries
(Not supported by EPCglobal Class 1 Gen 2 tags) Sets the number of
times a group unselect is attempted. Valid range is 1 (default) to 254.

Session

(EPCglobal Class 1 Gen 2 tags only) Sets the command session
parameter to the corresponding EPCglobal Class 1 Gen 2 air protocol
command (default is QueryAdjust).

This setting is equivalent to the SESSION BRI attribute. For more
information on this setting, see the EPCglobal Class 1 Gen 2
documentation.

Initial Q

(EPCglobal Class 1 Gen 2 tags only) Sets the initial Q parameter value
used by the Query command. Valid range is 0 to 15 (default is 4). If
you know there is only one tag in the field, set this attribute to 0 for
best performance.

This setting is equivalent to the INITIALQ BRI attribute.
Initialization Tries

Sets the maximum number of times the reader attempts to initialize a
tag. Valid range is 1 (default) to 254.
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This setting is equivalent to the INITTRIES BRI attribute.

ID Tries
Sets the maximum number of times the reader executes the identify
algorithm before a response is returned to a Read or Write command.

In practice, this is the number of times a tag ID attempt is made for
each antenna being used. Valid range is 1 to 254 (default is 3).

This setting is equivalent to the IDTRIES BRI attribute.

ID Timeout

Sets the ID timeout value (in ms) when Timeout Configuration mode
is enabled. Range is 0 to 65534 (default is 100). This setting is visible
only if Timeout Configuration mode has been enabled. For help, see
“Timeout Configuration Mode” in this section.

This setting is equivalent to the IDTIMEOUT BRI attribute.

Antenna Tries
Sets the maximum number of ID Tries that the reader executes per
antenna. Valid range is 1 to 254 (default is 3).

This setting is equivalent to the ANTTRIES BRI attribute.

Antenna Timeout

Sets the antenna timeout value (in ms) when Timeout Configuration
mode is enabled. Range is 0 to 65534 (default is 50). This setting is
visible only if Timeout Configuration mode has been enabled. For
help, see “Timeout Configuration Mode” in this section.

This setting is equivalent to the ANTTIMEOUT BRI attribute.

Dense Reader Mode

Check this check box to enable dense reader mode, which is only

supported by EPC Class 1 Gen 2 tags. When dense reader mode is
enabled, these tags respond with Miller Sub carrier encoded data

instead of FMO encoded data.

LBT Scan Enable

(Supported only by 865 MHz readers) Enables Listen Before Talk
(LBT) scanning. LBT scanning is enabled by default (disabled by
default on IF61 models with 4 channels).
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When LBT scanning is enabled, the algorithm scans the available
ETSI 302-208 channels for a free transmit channel. The scan sequence
begins with the channel specified by LBT Channel (default is 8), and
every third channel is checked (for example, 8, 11, 4,7, 10, 13,6, 9, 12,
5) until a free channel is found. If a free channel is not found, LBT
repeats the scan sequence.

When LBT scanning is not enabled, the IF61 does not scan for a free
transmit channel, and the transmit channel is set by LBT Channel.

LBT Channel

(Supported only by 865 MHz readers) Sets the default transmit
channel (of the available ETSI 302-208 channels). When LBT
scanning is enabled, the channel scan sequence starts with this
channel. When LBT scanning is not enabled, this is the only transmit
channel used. Range is 4 to 13 and default channel is 8.

For IF61 models with 4 channels, choose from channels 4, 7 (default),
10, or 13.

Field Strength1to 4
Sets the RF power level (in dBm) for each of the 4 antenna ports. Valid
range is 15 to 30 (maximum power). Default is 30.

Use this setting to attenuate the antenna field strength. In some
situations, full output power can cause unnecessary interference. For
example, if the tag is close to the antenna, full output power might
overload the tag and cause unreliable behavior.

This setting is equivalent to the FIELDSTRENGTH BRI attribute.

Antenna Sequence: First through Eighth

Sets the RFID antenna to be used for each of up to eight tag inventory
operations. Choose any one of the four available antennas from the
drop-down list. If more than one antenna is enabled, the antennas fire
in this sequence.

This setting is equivalent to the ANTS BRI attribute.
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Configuring the BRI Server

The IF61 BRI server handles communication between your
application and the RFID module. When your application is
communicating with the BRI server, the blue Intermec Ready-To-
Work Indicator on the IF61 front panel turns on and stays on. For
more information, see “About the Intermec Ready-To-Work
Indicator” on page 7.
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To configure BRI server settings

1 From the menu, click RFID Services > BRI > BRI Server. The BRI
Server screen appears.

[ ) RFID
Navigation Menu

Intermec’

BRI Server

Tuesday, April 22, 2008 04:12:13

- [l Network Configuration
B RFID Services

BRI Attributes
-1 | BRILog
L i
B Edgeware Applications
- [ Security

B Maintenance

About

Intermec Manual Help

|
| Enable External BRI Connections

- Basic Reader Interface (BR) ——————————————————
| BRI TCP Port [289 |
| 2189 |

&3

'lEnab\a Logging

[a)

2 Change BRI server settings as needed. For help, see the next table.

3 Click Activate Changes to save your changes and immediately
make them active.

BRI Server Parameter Descriptions

Parameter

Enable External
BRI Connections

BRI TCP Port

Enable Logging

Description

Enables/disables external TCP connections to the BRI
server. If this check box is not checked, the BRI server

only accepts connections from applications installed on
the IF61.

Specifies the TCP port used for incoming connections
to the BRI server. This port must be unique for all TCP
services running on the IF61. Valid range is 2189 to
65535. Defaultis 2189.

Enables/disables logging of BRI server events.

For more information on logging, see the next section.
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Viewing the BRI Server Log

If you enable logging, you can see a list of BRI server events. You can
save the logfile as a .txt file.

To enable BRI server logging and view the logfile

1 Enable BRI logging as described in the previous section,
“Configuring the BRI Server.”

2 In the left navigation list, click RFID Services > BRI > BRI Log.
The BRI Log screen appears with a list of BRI events. For more
information on server events, see the next table, “BRI Event
Descriptions.”

Intermec’
@ RFID

Navigation Menu BRI Log

Intermec Manual Help
Tuesday, April 22, 2008 0 2

B8 Network Configuration

-l Maintenance

About

Export log to text fle

1 = Command received by BRI Server
B8 RFID Services 2 = Response sent from BRI Server =
3 = BRI Server connection message 3

&[0 BRI Log captured by user — 04/22/2008 04:13:02.12
BRI Server Time/Date Connection Type Message
04/22/2008 04:06:02.832 3 0003 BRI ICP client succesafully started
BRIAttributes  |gay22/2008 3 o001 vER
BRI Log 3 a[ulsb3 IXSI 'ID Reader Y-'EI- g.22 .
3 o0z Besic Reader Interface Version 3.10
LLRP 3 o0z FCC S15MHz CCD14
3 i 3 o0z Copyright (C) 2008 Intermec Tachnologies Corp
B Edgeware Applications = B0 =
B Security 3 o001 TRIGEERHALT
3 000z oR>

[

3 To save the log file, click Export log to text file and then choose

File > Save As. Follow the prompts to save the log file to your
desktop PC.

BRI Event Descriptions

Event Name Description

Time/Date

Connection

Type

Message
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Time and date of the event.
TCP port of the event. 0 indicates a serial connection.

Message type of the event, generally indicating which system
sent the message:

1 = Command received by BRI server
2 = Response sent by BRI server
3 = BRI server connection message

Text of the message, including responses.
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Configuring LLRP Settings

The IF61 supports version 1.0.1 of the EPCglobal Low-Level Reader
Protocol (LLRP), which establishes a specific interface method
between a reader and its corresponding client. Follow the next
procedure to configure LLRP settings.

74

%

Note: For information on LLRP, including standards, see

http://www.epcglobalinc.org/standards/llrp.

To configure LLRP settings
1 From the menu, click RFID Services > LLRP. The LLRP screen

appears.
eS|
2
Intermec’ Intermec Manusl Help
[) RFID Thursday, March 20, 2008 21:50:07
Mavigation Menu

& Network Configuration
@8 RFID Services
- BRI
LLRP
@l Edgeware Applications
B8 security
~ 8 Maintenance
About

- EPCglobal Low-Level Reader Protocol (LLRP) Options

Secure Server Enable

Unsecure Server Enable

- Forced Client Termination

- Reader-Initiated Connections

Client Address i
TCP Port

Enable Security (TLS)

2 Configure LLRP settings as needed. For help, see the next table.

* To disconnect an existing LLRP connection, click Terminate.

e To connect to a remote LLRP client, enter information in the
Reader-Initiated Connections section, and then click Initiate.
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3 Click Activate Changes to save your changes and immediately
make them active.

LLRP Settings Descriptions

Setting

Secure Server
Enable

Unsecure Server
Enable

Reader-Initiated
Connections

Description

Check this check box to allow connections to the secure
LLRP server on port 5085.

Check this check box to allow connections to the
unsecure LLRP server on port 5084.

For reader-initiated TCP/IP connections to a remote

LLRP client, enter this information:

* Client Address - IP address of the remote LLRP
client.

* TCP Port - Port number for the TCP/IP socket
connection.

* Enable Security (TLS) - Check this check box to
enable Transport Layer Security for this TCP/IP
connection.

About the Developer Tools

Use the Developer Tools for basic testing of your RFID system. The
Developer Tools support these features:

* General purpose input/output (GPIO) testing. For help, see the

next section.

* Sending BRI commands or BRI script files to the IF61 from an
interactive browser interface. For help, see “Sending BRI
Commands and Running Scripts” on page 76.

* Editing and testing JavaScript files. For help, see “Using the
Workbench” on page 78.

see “About the IF61 Edgeware Applications” on page 63.

& Note: To use the Developer Tools, you need to enable them. For help,
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Testing the GPIO Interfaces

If you have external GPIO controls such as motion sensors or
indicator lamps connected to the IF61, you can use the Diagnostics
tool to test the interfaces and verify that the controls behave as

expected. Leave the controls connected to the IF61 GPIO port when
using the Diagnostics tool.

To test the GPIO interfaces

1 From the menu, click Edgeware Applications > Developer Tools
> GPIO. The GPIO screen appears.

Intermec* Intermec Manual Help
RFID

S

Navigation Menu

Wednesday, April 23, 2008 06:23:17
GPIO

B Network Configuration

B8 RFID Services

B Edgeware Appiications
Application Cantrel

-1 | Install Edgeware

i1 | Install User Application

- GPIO
GPIO Channel
Loz E &
Input: (Currently active If checked)
output: [ [ [ [ (Check to activate)

Read and Write GPIO

Mearing

B Developer Tools
| BRI Commands
i i |erio
Workbench
ALE Engine
88 IBM Data Capture and Delivery Platform
BB ALE Store and Forward

B 5AP Device Contraller

When this screen appears, the four IF61 GPIO interfaces are
turned off.

2 Check the check box for each of the GPIO interfaces you want to
test. When you check the check box, that GPIO output will be
turned on, and its associated GPIO input is turned on.

3 Click Read and Write GPIO. The GPIO interface state is changed.

Sending BRI Commands and Running Scripts

You can send BRI commands to the IF61 or load and run a BRI script
through the web browser interface. For more information on BRI
commands and syntax, see the BRI programmer’s reference manual.

To send BRI commands

1 From the menu, click Edgeware Applications > Developer Tools
> BRI Commands. The BRI Commands screen appears.
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|
.
Ny [ntermec e i He
Wednesday, April 23, 2008 06:31:58
[) RFID dnesd; i
Navigation Menu BRI Commands
~
B Network Configuration  Execute a BRI il
- i RFID Services "
-l Edgeware Applications (Command: | 3
Application Control
3 r Run a BRI script
Install Edgeware
Install User Application Kot ” R ‘ Load
-l Developer Tools
| BRI Commands =
GPIO
Workbench
ALE Engine 1
8 IBM Data Capture and Delivery Platform
- ALE Store and Forward
[l SAP Device Controller
=l v

2 Enter the BRI command in the Command entry field.

3 Click Run. The command is executed and return values appear
onscreen. For example, if you sent the ATTRIB command, the
reader attributes appear in the list.

[]
.
'\\\ Intermec Intermec Manual Help
[ ) RFID Wednesday, April 23, 2008 07:29:49
Navigation Menu BRI Commands
~
~ il Network Configuration  Executea BRI (n
@l RFID Services ;
B Edgeware Applications Command; | |
Application Control
3 r Run a BRI script
Install Edgeware
Install User Application b [ Emwser] [ Load
B8 Developer Tools
L. | BRI Commands [Osing reader bridevi] ~
@0 [Execute command] (Al
BNTS=1
Workbench TAGTYPE=EPCCI1G2 | E
ALE Engine FIELDSEP=" " =
FIELDSTRENGTH=30DB, 30DB, 30D8, 30DB

B8 BV Dats Capture and Delivery Platform | oo o

~ Bl ALE Store and Forward CHRSUM=OFF

BB SAP Device Controller HOTAGRPT=CN 3

IDREPORT=CN =
B Security SESSION=2
B Maintenance INITIALQ=4
sbout INITIRIES=1
IDTRIES=1
BNTTRIES=3
IDTIMEOUT=100
BNTTIMEOUT=50
RDTRIES=3 —= 4
WRTRIES=3
LOCKIRIES=3
SELTRIES=1 e W
Copyright € 1995-2008 Intermec & Technologies Corparation L]
b

To load and run a BRI script

1 From the menu, click Edgeware Applications > Developer Tools
> BRI Commands. The BRI Commands screen appears.
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2 Click Browse and browse to the location of the BRI script.

3 Double-click the name of the file. The script filename appears in
the Script name field.

4 Click Load. The script is loaded and run, and return values appear
onscreen.

Using the Workbench

%

78

You can create and edit a JavaScript file, load the file on the IF61, and
run the file from the Workbench.

Note: These instructions assume you understand how to create and
edit JavaScript files.

To create and run a JavaScript file

1 From the menu, click Edgeware Applications > Developer Tools
> Workbench. The Workbench screen appears.

. Intermec* Intermec Manual Help

RFID \Wednesday, Apri 23, 2008 07:35:56

Navigation Menu Workbench
o)
B Network Configuration JavaScript Code |
B RFID Services Fie: [ New... [w]

-l Edgeware Applications
Application Control
Install Edgeware
Install User Application

B8 Developer Tools

&1 | BRI Commands
GPIO
Workbench

ALE Engine

B8 1BM Data Capture and Delivery Platform

BB ALE Store and Forward

B9 SAP Device Controller

B secuity
B Maintenance
" | About
|[Run]
Output Pane
<] il | | &
Copyright € Intermec @ Technol rporatio
e

2 Click in the JavaScript Code box to enter code. You can also paste
text copied from Notepad or another application. Copy the text
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from the other application and choose Edit > Paste in the browser
menu.

3 To save your JavaScript code to the IF61 work buffer, click Save As
and enter a new file name in the entry field. Click OK.

If you previously saved your JavaScript, click on the drop-down
menu and select the file name to reload it in the JavaScript Code
box.

4 Click Run. The IF61 runs the JavaScript. Responses from the
reader appear in the output pane. For example, if your script
instructed the reader to read tags, the tag IDs appear in the
Output Pane.

Intermec’ e ek e
. L Int Manual Help

Wednesday, April 23, 2008 07:44:40

Navigation Menu Workbench
Javascript Code

-~ Network Configuration te: [tosti [ [ Sove]| [ Seve A

-l RFID Services

B i AR var reader, results:
reader = new BRI():
Appiicatidn Contre) results = reader.execute ("READ");
Install Edgeware print (results):
Instal User Application
B8 Developer Tools
L1 | BRI Commands
GPIO 3
Workbench =
ALE Engine
B8 1BM Data Capture and Delivery Platform
B8 ALE Store and Forward
Gl SAP Device Controller
- Security
B Maintenance

About

r Output Pane
[Execute posted script]
HA01A051011A224135A011002, HAO1A0510114224137A011102, HA01A051011A22413230

[Posted script end] [s]
< m |2l u

Logout Copyright € 1995-2008 Intermec @ Technologies Corporation
[om)]
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Managing, Troubleshooting, and
Upgrading the IF61

This chapter includes information on managing the IF61
and includes these topics:

Managing the IF61
Using the Device Configuration Web Service

Using Simple Network Management Protocol
(SNMP)

Using SmartSystems Foundation

Using Wavelink Avalanche

Importing and Exporting Files
Accessing the IF61 via the Linux Shell
Opening a Serial Connection to the IF61
Maintaining the IF61

Troubleshooting the IF61

Calling Intermec Product Support
Accessing Intermec Web Pages

Upgrading Firmware
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Managing the IF61

There are several methods you can use to manage the IF61. You can
use:

* aweb browser. For help, see “Using the Web Browser Interface”
on page 12. This manual assumes you are using this method for
all procedures.

* the Device Configuration web service. For help, see the next
section.

* an SNMP management station. For help, see “Using Simple
Network Management Protocol (SNMP)” on page 84.

* the Wavelink Avalanche client management system. For help, see
“Using Wavelink Avalanche” on page 89.

* the Intermec SmartSystems Console. For help, see “Using
SmartSystems Foundation” on page 86.

Using the Device Configuration Web Service

82

The Device Configuration web service provides a way to
programmatically configure the IF61 over your network. This SOAP-
based service provides a configuration API that allows you to specify a
variety of network, RFID, edgeware application, and system settings
via XML-encoded messages.

Follow the next procedure to enable the web service or to download
the Device Configuration web service description language (WSDL)
document.

For more information on the Device Configuration web service, see
the Device Configuration Web Service Command Reference Manual (P/N
937-012-xxx).
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To enable the web service and download the WSDL document

1 From the menu, click Network Configuration > Device
Management. The Device Management screen appears.

Intermec*
8

RFID

Mavigation Menu

Device Management

Intermec Manual Help
Thursday, March 20, 2008 :58

B8 Network Configuration
Ethernet
-~ 802,11
Common
Device Management
Services
B RFID Services
- [ Edgeware Applications
B security

B Maintenance

About

r Device Configuration Web Services

Enable Device Web Services (Insecure)

Enable Device Web Services (Secure)
Download WSDL File: DeviceConfiguration. wsdl
Enable Avalanche Access
Avalanche Agent Name |
r SmartSystems

Enable SmartSystems Access

SmartSystems Server Address ]

- SNMP

Enable SNMP Access

SNMP Community (Read-Only)  [public ]

SHMP Commurity (Read/Write)  |private |

SNMP Trap Target 1 |
SNMP Trap Target 2 |

By default, Device Configuration web services are enabled for
either secure or insecure connections.

2 To disable web services over a secure connection, uncheck the
Enable Device Web Services (Secure) check box, and then click
Activate Changes.

[l

To disable web services over an insecure connection, uncheck the
Enable Device Web Services (Insecure) check box, and then
click Activate Changes.

To download the device configuration WSDL document, click
DeviceConfiguration.wsdl. The document opens in the browser

window.
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<?xml version="1.0" encoding="UTF-8" 7>
- =definitions name="DeviceConfiguration" targetNamespace="http://10.10.102.9:64907 /DeviceConfiguration.wsdI"
xmins: tns="http://10.10.102.9:64907 / DeviceConfiguration.wsdl" xmins:SOAP-
ENV="http://schemas.xmlsoap.org/soap/envelope/" xmins: SOAP-
ENC="http://schemas.xmlsoap.org/soap/encoding/" xmins:xsi="http:/ /www.w3.org/2001/XMLSchema-instance"
xmins:xsd="http://www.w3.0rg/2001/XMLSchema" xmins:idws="idws"
xmins: S ttp:/ /schemas.xmlsoap.org/wsdl/soap/" xmins:MIME="http:/ /schemas.xmlsoap.org/wsdl/mime/"
xmins:DIME="http:/ /schemas.xmlsoap.org/ws/2002/04/dime/wsdl/"
xmins:WSDL="http:/ /schemas.xmlsoap.org/wsdl/" xmins="http:/ /schemas.xmlsoap.org/wsdl/">
- <types=
- <schema targetNamespace="idws" xmlns: SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
xmins:SOAP-ENC="http:/ /schemas.xmlsoap.org/soap/encoding/"
xmins:xsi="http:/ /www.w3.0rg/2001/XMLSchema-instance"
xmins:xsd="http:/ /www.w3.org/2001/XMLSchema" xmins:idws="idws"
xmins="http:/ /www.w3.org/2001/XMLSchema" elementFormDefault="qualified"
attributeFormDefault="unqualified">
<import namespace="http://schemas.xmlsoap.org/soap/encoding/" />
- <simpleType name="ReadyToWorkState">
- <restriction base="xsd:string">
<enumeration value="RTW-Error" /=
<l=- enum nst = 0 i
<enumeratmn value "RTW-Warning" />
<l--  enum s e
<enumeration value “RTW Ready" />
<!-- enum const = 2 o
<frestriction=
</simpleType>
- <simpleType name="RadioMode">
- <restriction base="xsd:string"=
<enumeration value="RadioMode-Unknown" />
<l-- en const = ==
<enumerat|un value "RadioMode-Auto" /= —

The DeviceConfiguration.wsdl document.

Using Simple Network Management Protocol

(SNMP)

84

You can access and manage the IF61 from a Simple Management
Network Protocol (SNMP) station. Contact your Intermec
representative for a copy of the management information base (MIB).

Before you can use an SNMP management station, you need to:

* enable SNMP access to the IF61. By default, SNMP access is
enabled.

* define the IF61 SNMP community strings.
To enable SNMP access and define SNMP community strings

1 From the menu, click Network Configuration > Device
Management. The Device Management screen appears.

Because SNMP access is enabled by default, the Enable SNMP
Access check box is checked, and a list of configurable settings
appears in the SNMP list.

IF61 Fixed Reader User’s Manual



Chapter 4 — Managing, Troubleshooting, and Upgrading the IF61

RFID

Navigation Menu

Intermec*
D

|
Intermec  Manu

Thursday, March 20, 2008 08:
Device Management

Ethernet
- 80211

Common

Services
B8 RFID Services

[ Security

B8 Maintenance

About

- Network Configuration

Device Management

@ Edgeware Applications

- Device Configuration Weh Services

Enable Device Web Services (Insecure)
Enable Device Web Services {Secure) 5
Download WSDL File: DeviceConfiguration, wsdl
lanch
Enable Avalanche Access

avalanche Agent Name |

- SmartSystems

Enable SmartSystems Access g

SmartSystems Server Address ]

r SNMP

Enable SNMP Access

SNMP Community (Read-Only) public

SNMP Community (Read/Write)  [private |

SNMP Trap Target 2 | 2

2 Configure SNMP settings for your network. For help, see the next

table.

3 Click Activate Changes to save your changes and immediately
make the changes active.

SNMP Community Parameter Descriptions

Parameter

Enable SNMP Access
SNMP Community (Read-Only)

SNMP Community (Read/
Write)

SNMP Trap Target 1
SNMP Trap Target 2

SNMPv3 Username (Read-
Only)

SNMPv3 Password (Read-Only)

IF61 Fixed Reader User’s Manual

Description

Uncheck this check box to disable SNMP access to the IF61.
SNMP access is enabled by default.

Password for read-only access. Range is 1 to 15 characters, case-
sensitive. Defaultis public.

Password for read/write access. Range is 1 to 15 characters, case-
sensitive. Defaultis private.

Authoritative name for trap target 1.
Authoritative name for trap target 2.

User name for SNMPv3 read-only access. Default is
readonly.

Password for SNMPv3 read-only access. Default is intermec.

85



Chapter 4 — Managing, Troubleshooting, and Upgrading the IF61

SNMP Community Parameter Descriptions (continued)

Parameter Description

SNMPv3 Authentication Type  Specifies the protocol for encrypted SNMPv3 messages. This
(Read-Only) must match a supported encryption protocol on the SNMP
management station. Choose MDS5, SHA1 (default), or None.

SNMPv3 Privacy Type (Read-  Specifies the protocol for read-only access to encrypted

Only) SNMPv3 messages. Must match a supported protocol on the
SNMP management station. Choose DES, AES (128 bit), or
None. Default is AES (128 bit).

SNMPv3 Username (Read/ User name for SNMPv3 read/write access. Default is
Write) intermec.

SNMPv3 Password (Read/ Password for SNMPv3 read/write access. Default is
Write) intermec.

SNMPv3 Authentication Type  Specifies the protocol for encrypted SNMPv3 messages. This
(Read/Write) must match a supported encryption protocol on the SNMP
management station. Choose MDS, SHA1 (default), or None.

SNMPv3 Privacy Type (Read/  Specifies the protocol for read/write access to encrypted

Write) SNMPv3 messages. Must match a supported protocol on the
SNMP management station. Choose DES, AES (128 bit), or
None. Default is AES (128 bit).

Using SmartSystems Foundation

The IF61 ships with a SmartSystems™ Client, which means you can
manage it from a central host PC using Intermec’s SmartSystems
Foundation. The SmartSystems Console displays all discovered
SmartSystems devices in your network.

For more information on SmartSystems Foundation, go to
www.intermec.com/SmartSystems. For information on using the
SmartSystems Console, in the Console choose SmartSystems > Help.

To use SmartSystems Foundation

1 From the menu, click Network Configuration > Device
Management. The Device Management screen appears.
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On the IF61, SmartSystems is enabled by default.

)
.
lntermec Intermec  Mal
Thursday, March 20, 2008 08:
Navigation Menu Device Management
- [ Network Configuration
Ethernet
~@ ez - Device Configuration Web Services
ig
Comman Enable Device Web Services {Insecure)
Device Management
Enable Device Web Services {Secure) E
Services T3
BB RFID Services Download WSDL File: DeviceConfiguration, wsdl
@8 Edgeware Applications
lanch
-l Security
BB Maintenance Enable Avalanche Access
About Avalanche Agent Name ]
- SmartSystems
Enable SmartSystems Access i
SmartSystems Server Address ]
[ SNMP
Enable SNMP Access
SNMP Community (Read-Only) public
SNMP Community (Read/Write)  [private |
SNMP Trap Target 1 |
SNMP Trap Target 2 | ]

2 To automatically connect to the SmartSystems server at boot time,
enter the server address in the SmartSystems Server Address
entry field. After you specify the server address, SmartSystems will
discover the IF61 during the next broadcast interval.

To disable SmartSystems access to the IF61, uncheck the Enable
SmartSystems Access check box.

3 Click Activate Changes to save your settings and immediately
make them active.
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